Opened 15 years ago

Closed 10 years ago

#228 closed defect (fixed)

trace_create() not working in libtrace application

Reported by: tyo@… Owned by: perry
Priority: major Milestone: libtrace3
Component: libtrace-library Version: 3.0
Keywords: Cc:

Description

Calling trace_create() initialises libtrace properly by internally calling trace_init() trace_create_dead() doesn't however.

Change History (6)

comment:1 Changed 15 years ago by perry

  • Resolution set to invalid
  • Status changed from new to closed

Fixed in r1018

comment:2 Changed 15 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:3 Changed 15 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r1018 (resolution Fixed, not invalid)

comment:4 Changed 12 years ago by anonymous

  • Summary changed from trace_create_dead() doesn't call trace_init() to qwfeagrhtfjygkuhli;j'koolikuyjthrgefw

qwfeagrhtfjygkuhli;j' koolikuyjthrgefw

comment:5 Changed 10 years ago by monika.sal@…

  • Milestone set to libtrace3
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from qwfeagrhtfjygkuhli;j'koolikuyjthrgefw to trace_create() not working in libtrace application
  • Version set to 3.0

I am finding problem invalid free while using trace_create().How to solve this problem.Can I get the source code of trace_create or the header file in which it is located.I 'll be really thankful to you.

comment:6 Changed 10 years ago by salcock

  • Cc j.ridoux@… removed
  • Resolution set to fixed
  • Status changed from reopened to closed

Should be fixed in r1687 - although I'm not clear on how one might hit that problem. If it continues, please submit the code you are using and the command line that you are trying to run it with to contact@… so that it is easier for us to try and replicate your problem. Thanks!

Note: See TracTickets for help on using tickets.