Changeset 77285d9 for configure.in


Ignore:
Timestamp:
05/10/06 09:57:52 (14 years ago)
Author:
Shane Alcock <salcock@…>
Branches:
4.0.1-hotfixes, cachetimestamps, develop, dpdk-ndag, etsilive, getfragoff, help, libtrace4, master, ndag_format, pfring, rc-4.0.1, rc-4.0.2, rc-4.0.3, rc-4.0.4, ringdecrementfix, ringperformance, ringtimestampfixes
Children:
3fcb8b4
Parents:
9b8c7ad
Message:

OpenBSD compatibility fixes - adding in various #defines and #includes that are needed to compile under OpenBSD
Added a replacement pcap_next_ex function for systems that aren't running pcap-0.8 or better

File:
1 edited

Legend:

Unmodified
Added
Removed
  • configure.in

    re5f1431 r77285d9  
    158158        fi
    159159   
    160         # Versions of libpcap earlier than 0.8 don't have pcap_dump_flush
     160        # Versions of libpcap earlier than 0.8 don't have pcap_dump_flush or
     161        # pcap_next_ex
    161162        AC_CHECK_LIB(pcap,pcap_dump_flush,
    162163                     have_pcap_dump_flush=true,
     
    165166        if test "$have_pcap_dump_flush" = false; then
    166167                AC_REPLACE_FUNCS(pcap_dump_flush)
     168        fi
     169       
     170        AC_CHECK_LIB(pcap,pcap_next_ex,
     171                     have_pcap_next_ex=true,
     172                     have_pcap_next_ex=false)
     173
     174        if test "$have_pcap_next_ex" = false; then
     175                AC_REPLACE_FUNCS(pcap_next_ex)
    167176        fi
    168177
Note: See TracChangeset for help on using the changeset viewer.