source: INSTALL @ 0ae5feb

4.0.1-hotfixescachetimestampsdevelopdpdk-ndagetsilivelibtrace4ndag_formatpfringrc-4.0.1rc-4.0.2rc-4.0.3rc-4.0.4ringdecrementfixringperformanceringtimestampfixes
Last change on this file since 0ae5feb was 0ae5feb, checked in by Shane Alcock <salcock@…>, 6 years ago

Add ./bootstrap.sh to install instructions

Anyone who clones us from github will need to run bootstrap
before they can do the standard ./configure; make; make install
routine.

Add mention of INSTALL to README.

  • Property mode set to 100644
File size: 1.4 KB
Line 
1Requirements:
2 * >=automake-1.9
3 * >=libpcap-0.8
4 * flex and bison
5
6Strongly recommended:
7 * zlib-dev (for reading and writing compressed traces)
8
9Optional:
10 * DAG libraries (both 2.4 and 2.5 versions are supported)
11----------------------------------
12
13Installing libtrace:
14
15./bootstrap.sh (only if you've cloned the source from GitHub)
16./configure
17make
18make install
19
20The above series of commands will install libtrace into /usr/local/lib. If
21you wish to install to a non-standard location, append the
22--prefix=DIR option to the ./configure command. ./configure also takes
23a number of other options - run ./configure --help to view a comprehensive
24list.
25
26You may need to add the library location (e.g. /usr/local/lib) to your
27/etc/ld.so.conf and run 'ldconfig' as root.
28
29----------------------------------
30
31Installation FAQ:
32
33Q. I've installed libpcap but I'm still getting the following error:
34"libpcap0.8 or greater is required to compile libtrace. If you have installed
35it in a non-standard location please use LDFLAGS to specify the location of
36the library"?
37
38A. You need to install the development version of the pcap library.
39For example, Ubuntu/Debian users will need to install the libpcap0.8-dev
40package in addition to the libpcap0.8 package.
41
42
43----------------------------------
44Using libtrace:
45
46The best source of information on how to use libtrace and the tools that come
47with it is the libtrace wiki located at
48http://www.wand.net.nz/trac/libtrace/wiki
49
50
Note: See TracBrowser for help on using the repository browser.