source: INSTALL @ 31111c7

cachetimestampsdevelopringdecrementfixringperformance
Last change on this file since 31111c7 was bbe691b, checked in by Shane Alcock <salcock@…>, 2 years ago

Update references to libwandio to refer to v4.0.0

Also add missing optional dependency on libwandder to INSTALL.

  • Property mode set to 100644
File size: 1.7 KB
RevLine 
[870cad4]1Requirements:
2 * >=automake-1.9
3 * >=libpcap-0.8
[a1b899f]4 * flex and bison
[bbe691b]5 * libwandio 4.0.0 (http://research.wand.net.nz/software/libwandio.php)
[a1b899f]6
7Optional:
8 * DAG libraries (both 2.4 and 2.5 versions are supported)
[fba3b72]9 * libcrypto (required for CryptoPAN anonymisation in traceanon)
10 * libncurses (required for tracetop)
[bbe691b]11 * libwandder (required for ETSI LI decoding --
12        https://github.com/wanduow/libwandder)
13
[a1b899f]14----------------------------------
15
[670d3de]16Installing libtrace:
17
[0ae5feb]18./bootstrap.sh (only if you've cloned the source from GitHub)
[6378b14]19./configure
[670d3de]20make
[a1b899f]21make install
[d9faaa5]22
[a1b899f]23The above series of commands will install libtrace into /usr/local/lib. If
[fba3b72]24you wish to install to a non-standard location, append the
[a1b899f]25--prefix=DIR option to the ./configure command. ./configure also takes
26a number of other options - run ./configure --help to view a comprehensive
27list.
[670d3de]28
[fba3b72]29You may need to add the library location (e.g. /usr/local/lib) to your
[a1b899f]30/etc/ld.so.conf and run 'ldconfig' as root.
[670d3de]31
32----------------------------------
[17094b2]33
34Installation FAQ:
35
[fba3b72]36Q. I've installed libpcap but I'm still getting the following error:
37"libpcap0.8 or greater is required to compile libtrace. If you have installed
38it in a non-standard location please use LDFLAGS to specify the location of
[17094b2]39the library"?
40
[fba3b72]41A. You need to install the development version of the pcap library.
42For example, Ubuntu/Debian users will need to install the libpcap0.8-dev
[0ae5feb]43package in addition to the libpcap0.8 package.
44
[17094b2]45
[b6cbdaf]46Q. What operating systems do you support?
47
48A. Linux, FreeBSD, Mac OS X and OpenBSD. Windows is not supported.
49
[17094b2]50----------------------------------
[670d3de]51Using libtrace:
52
[a1b899f]53The best source of information on how to use libtrace and the tools that come
[fba3b72]54with it is the libtrace wiki: https://github.com/wanduow/libtrace/wiki
[670d3de]55
[d18312c]56
Note: See TracBrowser for help on using the repository browser.